原创

js 块级作用域

小郝不负流年
小郝不负流年   + 关注
2020-11-17 20:20:14   阅读12   评论0

为什么需要块级作用域?

ES5 只有全局作用域和函数作用域,没有块级作用域,这带来很多不合理的场景。


第一种场景,内层变量可能会覆盖外层变量。

var tmp = new Date();

function f() {
   console.log(tmp);
   if (false) {
      var tmp = 'hello world'; 
   }
}

f(); // undefined

上面代码的原意是,if代码块的外部使用外层的tmp变量,内部使用内层的tmp变量。但是,函数f执行后,输出结果为undefined,原因在于变量提升,导致内层的tmp变量覆盖了外层的tmp变量。


第二种场景,用来计数的循环变量泄露为全局变量。

var s = 'hello';

for (var i = 0; i < s.length; i++) {
    console.log(s[i]);
}
console.log(i); // 5

上面代码中,变量i只用来控制循环,但是循环结束后,它并没有消失,泄露成了全局变量。


ES6 的块级作用域

let实际上为 JavaScript 新增了块级作用域。

function f1() {
    let n = 5;
    if(true) {
        let n = 10;
    }
    console.log(n); // 5
}

上面的函数有两个代码块,都声明了变量n,运行后输出 5。这表示外层代码块不受内层代码块的影响。如果两次都使用var定义变量n,最后输出的值才是 10。


ES6 允许块级作用域的任意嵌套

{
    {
        {
            {
                {
                    let insane = 'Hello World'
                }
                console.log(insane); // 报错
            }
        }
    }
};

上面代码使用了一个五层的块级作用域,每一层都是一个单独的作用域。第四层作用域无法读取第五层作用域的内部变量


内层作用域可以定义外层作用域的同名变量。

{
    {
        {
            {
                let insane = 'Hello World'; 
                {
                    let insane = 'Hello World'
                }
            }
        }
    }
};

块级作用域的出现,实际上使得获得广泛应用的匿名立即执行函数表达式(匿名 IIFE)不再必要了。

// IIFE 写法
(function () {
     var tmp = ...; 
     ...
}());

// 块级作用域写法
{ 
      let tmp = ...; 
      ...
}


块级作用域与函数声明

函数能不能在块级作用域之中声明?这是一个相当令人混淆的问题。

ES5 规定,函数只能在顶层作用域和函数作用域之中声明,不能在块级作用域声明。

// 情况一
if (true) {
      function f() {}
}

// 情况二
try { 
     function f() {}
} catch(e) { 
      // ...
}

上面两种函数声明,根据 ES5 的规定都是非法的。

但是,浏览器没有遵守这个规定,为了兼容以前的旧代码,还是支持在块级作用域之中声明函数,因此上面两种情况实际都能运行,不会报错。

ES6 引入了块级作用域,明确允许在块级作用域之中声明函数。ES6 规定,块级作用域之中,函数声明语句的行为类似于let,在块级作用域之外不可引用

function f() {
    console.log('I am outside!'); 
}

(function () {
    if (false) {
       // 重复声明一次函数f
       function f() {
           console.log('I am inside!'); 
        } 
     }
     f();
}());

上面代码在 ES5 中运行,会得到“I am inside!”,因为在if内声明的函数f会被提升到函数头部,实际运行的代码如下。

// ES5 环境
function f() {
   console.log('I am outside!'); 
}

(function () {
    function f() {
      console.log('I am inside!'); 
    } 
    if (false) { 
    } 
    f();
}());

ES6 就完全不一样了,理论上会得到“I am outside!”。因为块级作用域内声明的函数类似于let,对作用域之外没有影响。但是,如果你真的在 ES6 浏览器中运行一下上面的代码,是会报错的,这是为什么呢?

// 浏览器的 ES6 环境
function f() { 
   console.log('I am outside!'); 
}

(function () {
   if (false) { // 重复声明一次函数f
      function f() { console.log('I am inside!'); } 
    }
   f();
}());
// Uncaught TypeError: f is not a function

上面的代码在 ES6 浏览器中,都会报错。

原来,如果改变了块级作用域内声明的函数的处理规则,显然会对老代码产生很大影响。为了减轻因此产生的不兼容问题,ES6 在附录 B里面规定,浏览器的实现可以不遵守上面的规定,有自己的行为方式

  •     -  允许在块级作用域内声明函数。
  •     -   函数声明类似于var,即会提升到全局作用域或函数作用域的头部。
  •     -   同时,函数声明还会提升到所在的块级作用域的头部。

注意,上面三条规则只对 ES6 的浏览器实现有效,其他环境的实现不用遵守,还是将块级作用域的函数声明当作let处理。

根据这三条规则,浏览器的 ES6 环境中,块级作用域内声明的函数,行为类似于var声明的变量。上面的例子实际运行的代码如下。

// 浏览器的 ES6 环境
function f() { console.log('I am outside!'); }
(function () {
  var f = undefined;
  if (false) {
    function f() { console.log('I am inside!'); }
  }


  f();
}());
// Uncaught TypeError: f is not a function

考虑到环境导致的行为差异太大,应该避免在块级作用域内声明函数。如果确实需要,也应该写成函数表达式,而不是函数声明语句。

// 块级作用域内部的函数声明语句,建议不要使用

{
  let a = 'secret';
  function f() {
    return a;
  }
}


// 块级作用域内部,优先使用函数表达式
{
  let a = 'secret';
  let f = function () {
    return a;
  };
}

另外,还有一个需要注意的地方。ES6 的块级作用域必须有大括号,如果没有大括号,JavaScript 引擎就认为不存在块级作用域。

// 第一种写法,报错
if (true) let x = 1;


// 第二种写法,不报错
if (true) {
  let x = 1;
}

上面代码中,第一种写法没有大括号,所以不存在块级作用域,而let只能出现在当前作用域的顶层,所以报错。第二种写法有大括号,所以块级作用域成立。

函数声明也是如此,严格模式下,函数只能声明在当前作用域的顶层。

// 不报错
'use strict';
if (true) {
  function f() {}
}


// 报错
'use strict';
if (true)
  function f() {}
对我有用,我要     转载  
文章分类: ES6  
所属标签: js   块级作用域  
  • 0条评论
  • 只看作者
  • 按时间|按热度
  • 由于本人多次涉及需要打印这个证明,而每次都会忘记入口,在网上各种搜索各种摸索很是浪费时间。故本次将操作流程整理记录下来,以备忘。同时也分享给大家。1、打开湖北政务服务网,地址:http://zwfw.hubei.gov.cn/s/index.html2、切换区域到“武汉市”3、在“特色服务”模块找到“(个人)武汉市社会保险公共服务平台”4、进入“(个人)武汉市社会保险公共服务平台”,登录账号密码<imgsrc="https://cdnstatic.hoscen.cn/blog/article/184053017752895488/img/497065960be44747825acb86a17483c1.png"style=
  • 1、找到nginx安装目录,找到nginx.conf ,  vi nginx.conf2、在http模块下面添加 server_tokens off;  ##隐藏版本号http {     ... 此处省略          server_tokens off;  ##隐藏版本号          ... 此处省略 }3、重启nginx4、效果如图,看不到版本号了
  • Thumbnailator,一个google开源的优秀的工具类 。根据提供的API可以快速实现图片缩放,区域裁剪,水印,旋转,保持比例 等操作。Thumbnailator官网:http://code.google.com/p/thumbnailator/ 本文主要讲图片原比例压缩功能。1、引入maven依赖2、demo测试public class TestImageUtil { public static void main(String[] args) throws IOException { String originImgPath = "C:UsersHoscenDesktopit.png"; String destImgPath = "C:UsersHoscenDesktopit-30.jpg"; Thumbnails.of(originImgPath) .scale(1f) .outputQuality(0.3f) .outputFormat("jpg") .toFile(destImgPath); } }3、测试结果原图,大小82.5kb<img src="https://static.hoscen.cn/blog/article/191329330033328128/img/5fa848b2b8f449bdb05dd78771777f83.png" style="width: 600px;" class="fr-fic fr-dib fr-fil
  • 一般我们在使用CDN时都设置有缓存时间,当源站资源发生变更后,如果缓存时间没到,那么用户访问的依旧是变更前的数据,虽说又拍云控制台提供了缓存刷新功能界面,但是每次都手动去刷新显示不太理想,当然又拍云也想到了这一点,提供给我们有API可以调用。本篇文章就是讲解如何接入又拍云缓存刷新API。网站免费接入又拍云CDN的方法,请查看我另外一篇文章,地址: https://www.hoscen.cn/blog/hao/articles/204022774975430656.html又拍云API文档:https://api.upyun.com/doc#/api/guide/overview看完文档,我们会知道又拍云提供有两个缓存刷新接口,一个支持通配符(但次数有限),一个是完整url刷新。同时注意调用接口时将 Token 放入 HTTP Header 中 。那么我们需要3个接口:1、获取token2、URL刷新3、缓存批量刷新详细请求参数和响应值请查看文档。话不多说,我们直接放上核心代码1、获取token2、URL刷新<img src="https://cdnstatic.hoscen.cn/blog/article/
  • 分享一个jQuery插件textarearesizer。它提供Resizer bar可拖动调整Textarea/div大小。代码示例:代码下载:    点击此处效果图:
  • 公益 404 页面介绍公益404页面是由腾讯公司员工志愿者自主发起的互联网公益活动。网站只需要在自己的404页面中嵌入一段简单的代码,就能通过互联网来迅速传播失踪儿童信息,从而提高找回失踪儿童的概率。失踪儿童信息来自宝贝回家寻子网。公益 404 页面接入方法:复制以下 js 代码,嵌入到您的 404 页面,可以自适应移动设备。<script type="text/javascript" src="//qzonestyle.gtimg.cn/qzone/hybrid/app/404/search_children.js" charset="utf-8"         homePageUrl="https://www.hoscen.cn/" homePageName="回到首页"></script>效果展示:注意事项:如果一个 404 页面的内容小于 512B,IE 会认为该 404 页面不够友好,在 IE 下将不会成功返回该 404 错误页面
  • 目录:1、安装node.js环境2、安装cnpm3、安装vue-cli脚手架构建工具4、用vue-cli构建项目5、安装项目所需的依赖6、项目运行7、项目打包1、安装node.js环境下载地址:https://nodejs.org/zh-cn/安装过程没有太多好说的,安装完成后 win+R打开命令行输入node -v , 如图,出现版本号说明安装成功。npm包管理器是集成在node中的 , npm -v可以查看版本2、安装cnpm由于有些npm有些资源被屏蔽或者是国外资源的原因,经常会导致用npm安装依赖包的时
  • XMind思维导图是做什么的,怎么使用,这些问题不在本次说明范围,本次就只做分享,一个XMind2020绿色免安装版分享!特点:1、无需安装,解压即用;2、可导出所有格式,不受限制;3、导出无水印;链接:https://pan.baidu.com/s/1jT0oXQS0Vxelsx1S2qVlRg 提取码:uew3 如果下载地址失效请留言反馈。资源来源朋友分享,仅供学习参考使用,请在下载后24小时内删除,请支持正版。
  • 网站内测进行中,为了发现未知的可能性错误,然后可以改正它,得到更加友好的网站用户体验。 欢迎大家反馈问题,可以通过留言版或qq或邮箱反馈。邮箱:hoscen@qq.comQ Q:102287680
  • 1真爱应该被定位为:温柔且有耐心的帮助对方成为更好的人。2不管身处怎样寒冷的冬季,只要想到你,心里就会不禁的温暖四起。3让我们每天带着希望出门,如果事与愿违,就再把希望带回家,休息休息,明天继续带出门。4我也太孤单了吧,连个偏旁部首都没有。5人间星火,竟无半点属于我。6如果总想着以后会遇到更好的人,那我们的相遇就毫无意义。7喜欢是晨曦前的朝露,喜欢是清风拂过山间,喜欢是想要触碰却收回的双手。8世间一切皆可努力,唯独相爱全凭运气。